Java / Spring Boot / Servlet Container

Flowable Engage is built on Java and Spring Boot. Spring Boot 2.1 RELEASE requires Java 8 or 11.

Explicit build support is provided for the following build tools:

Build Tool Version

Maven

3.2+

Gradle

4.x

Spring Boot supports the following embedded servlet containers:

Name Servlet Version

Tomcat 8.5.x

3.1

Jetty 9.4

3.1

Undertow 1.4

3.1

You can deploy Flowable Engage to any Servlet 3.1 or later compatible container but at least Tomcat 8.5.x is required and Tomcat 9.X is recommended.